Ulefone
  • Title: BLUBOO X9
  • Listed: 10/16/2015 4:53 pm
  • ROM Version: ROM Android 5.1
  • You must be logged for ROM download.



Overall Rating : 2

2184 total views, 1 today

4 Total favorites


  

BLUBOO X9

Author adMember Info

SoCr@Te

  • Listed by: SoCr@Te
  • Member Since: 05/15/0470

DESCRIPTION


ROM Mobile BLUBOO X9 – ROM Android 5.1

ONLY MT6753

Official ROM BLUBOO X9 Version: BLUBOO X9 20151013 – full_bd6753_65u_a_l1-user 5.1 LMY47D

Gapps include -  No Rooted

Language support : Multilang

 

Install ROM :

Install with SP MDT:

1). Turn off the smartphone. Cable is not connected to the computer.

2). Remove the battery and insert it again

3). Connect your phone to a computer cable. The operating system detects a new device

4). Disconnect the cable from the computer.

5). Run SPMultiPortFlashDownloadProject.exe

6). Choose File> Open File Agent download and specify the file MTK_AllInOneDA.bin (it is in the folder SP_MDT).

7). Click Scatter File and select the MT6753_Android_scatter.txt file (it's in the folder with the rom).

8). Click "Start all".

9). Connect your phone to a computer cable. The program should see and blink. If the phone is not detected, then unplug it from the computer,

 remove and insert the battery (if the battery is removable) and reconnect it to the computer.

10). After (OK) click Stop and disable any phone.

11). Completed.


Share Button

※Please make a backup of your device before installing or updating ROM


14 Responses to“BLUBOO X9”







  1. 01/08/2016
    Posts: 3

    Thancks for the ROM. After I installed I have a bug with the home button.





  2. 02/26/2016
    Posts: 4

    I concur with the previous poster… Thanks for making it available to us. It was the only way I had to unbrick my phone, and it did that wonderfully.

    After I started to use this ROM I realized -the previous poster also mentioned it- that there seems to be a bug with the capacitive buttons… It seems that a single tap on the buttons (at least "home" and "menu") is interpreted as a double tap. I have noticed that this Bluboo ROM predates the one installed in my phone when I received it (this one is from october, while mine was from late november or december, I do not remember exactly). In fact, the icon set in the launcher is slightly different from the one that came with the phone, among other things. Could it be that Bluboo fixed the little bugs in the final ROM that went into the shipped phones?

    Anyway, if that is the case it would be great it we could have a more up-to-date ROM based on Blueboo's latest released ROM.





    • 01/08/2016
      Posts: 5

      Good day, I can't find the original ROM that came with our phone, but I installed the ECOO E05 rom http://www.needrom.com/download/ecoo-e05/

      ECOO E05 – Update 11/09/2015

      which is the same phone I installed the ECOO E05 – Update 11/09/2015 first (Selected firmware upgrade when flashing) and it will update via OTA to the latest ROM ECOO_E05_151113  18-11-2015.

      The only problem is, and  I don't mind is that at start up it will show ECOO logo and the phone is recognized as an ECOO E05.

      The rest works fine for me, has the same icons as the original BUBOO.





  3. 02/26/2016
    Posts: 4

    Well, mnd123456, you were right: I was able to install the ECOO E05 ROM and carry out the OTA update without a hitch. It really seems to be the same ROM as the one in the Bluboo X9 except for the initial logo (and a few days of difference in the compilation date, so there might be some other minor differences; nothing apparent, though). Works fine, too, no obvious bugs so far. Moreover, after this I was able to install a TWRP recovery (3.0.0.0) which had been tailored to the X9 and root the phone. This also worked fine.

    Thanks a lot for pointing me in this direction!





  4. 02/26/2016
    Posts: 4

    Sure. I got the recovery from one of the administrators of a Spanish mobile phone forum,  he was nice enough to create it upon my request. Since it is working fine for me, he just made it available in a forum thread this very morning. I don't know if I am allowed to post URLs here, so I'll send you a PM with the details.

    Cheers.





  5. 01/08/2016
    Posts: 5

    Tank you for the link.





  6. 03/15/2016
    Posts: 1

    Hello,

    my 2 days old bluboo x 9 just doesnt do anything anymore. Display stays black all the time, no blinking notification or anything.

    Anyone got an idea?

    Thanks in advance!





    • 04/15/2016
      Posts: 3

      mine too is not working. i dont know what is the problem. il try to reinstall android





  7. 08/16/2015
    Posts: 1

    I had problems with signal and i tought changeing the rom

    So i flashed Bluboo x9 (official rom) and tried also  ECOO E05 rom but with both rom's i don't have any SIGNAL like i cant call to anyone …
    In sim management i have 2 sim card and i can see both numbers and sim's are inserted correctly.
    I HAVE CELLULAR DATA BUT NO SIGNAL ??? 

    Help pleaz !!!

     

    flashed them with SPFT





  8. 04/15/2016
    Posts: 3

    when i click on scatter it always says "the load scatter file is incorrect" in flash tool, or "incorrect scatter file" in SP MDT. What to do?





    • 02/26/2016
      Posts: 4

      If I recall correctly, this also happened to me with several ROMs. It was necessary to modify the first line of many of those scatter files, and remove the first word (maybe it is something left by the program used to create the file?). I don't have one of the original files right here (I am on Linux right now), but if I recall correctly it was something like this:

      First line of original scatter file: FIRSTWORD[xxxxxxxxx….

      First line of modified scatter file: [xxxxxxx

      So, you just remove that first label that is written in capitals, and try again.





  9. 10/03/2016
    Posts: 1

    Hi. Who can send me the usb drivers of Bluboo x9??





  10. 09/25/2016
    Posts: 1

    Hi! When installing firmware can generate CheckSum. ini when installing to the folder with the firmware and run the CheckSum Generate writes incorrect scatter format file. What am I doing wrong? Thank you.


Leave a Reply

You must be logged in to post a comment.

banner