• Title: Cyanogenmod 12.1
  • Listed: 03/19/2016 1:40 pm
  • ROM Version: Android 5.1.1
  • You must be logged for ROM download.

Overall Rating : 18

7701 total views, 1 today

3 Total favorites

2358 Total downloads


Cyanogenmod 12.1
Cyanogenmod 12.1 - Image 1Cyanogenmod 12.1 - Image 2Cyanogenmod 12.1 - Image 3Cyanogenmod 12.1 - Image 4Cyanogenmod 12.1 - Image 5Cyanogenmod 12.1 - Image 6Cyanogenmod 12.1 - Image 7

Author adMember Info


Install only using TWRP 3.0!!!

  1. Download the ROM
  2. Download GApps package
  3. Put the zip files on your SDCard
  4. Reboot in Recovery
  5. Wipe Data/Factory Reset
  6. Install CM12 zip file(our firmware)
  7. Install GApps zip file(google apps)
  8. install tp_wake_switch zip file(for normal operation of the touchscreen)
  9. Reboot system
  10. Enjoy CyanogenMod 12

For 166H install libaudio.primary.default.so​(/system/lib)

to increase the volume​ install libcustom_nvram.so​(/system/lib)

Does not work:
FM-radio (?),
hw codecs,
Unstable bluetooth headset,
screen recording,
streaming services (twitch.tv, etc.),

Correction of bad quality on youtube(360p):

  • using any file manager, go on the road data/data/com.google.android.youtube/shared_prefs
  • open the file "youtube.xml" with a text editor
  • Find the row ""
  • change it here on this line:  boolean name="h264_main_profile_supported5.1.1" value="true" />
  • Save this file

Sorry for my bad English!

Share Button

※Please make a backup of your device before installing or updating ROM

94 Responses to“Cyanogenmod 12.1”

  1. 11/28/2014
    Posts: 6

    Working but no sound in H version. Create patch

  2. 11/28/2014
    Posts: 6

    Ok i repair sound bug 166H i replace a LIB primary sound from original rom.

  3. 03/13/2016
    Posts: 11

    I like 12.1 :)

  4. 11/28/2014
    Posts: 6

    When i install your path sound phone stay at THL logo, to boot i must only change ,,libaudio.primary.default.so" but volume is very low, i try audio FX  but nothing help:/

  5. 03/13/2016
    Posts: 11

    The sound patch does not work, when installing the rom works, but when I install the sound patch does not start. It stays with the logo type of THL.

    I installed from the recovery, not whether to put it from there.

    please Help :/ :(

  6. 12/30/2014
    Posts: 21

    When i install the pro-supersu, it hooks. No reaktion after booting.

  7. 02/13/2016
    Posts: 3

    engineer mode not work

  8. 03/13/2016
    Posts: 11

    where is the sound fix?

  9. 03/13/2016
    Posts: 11

    You'll have it ready today?


  10. 03/13/2016
    Posts: 11

    I love the ROM. Thank you for teach, no doubt I will make a youtube video to teach how to put all this!  I'll do when you teach the audio patch  :)

Leave a Reply

You must be logged in to post a comment.