• Title: TWRP 3.0.2
  • Listed: 08/26/2016 4:39 pm
  • ROM Version:6.0
  • You must be logged for ROM download.

Overall Rating : 6

485 total views, 1 today

3 Total favorites


TWRP 3.0.2

Author adMember Info



Twrp 3.0.2 for Doogee X6 pro running Android 6.0

Share Button

※Please make a backup of your device before installing or updating ROM

7 Responses to“TWRP 3.0.2”

  1. 08/29/2016
    Posts: 1

    Thank You

  2. 09/08/2016
    Posts: 7

    Could you please post the instructions to install the TWRP on Android 6.0. Thanks you.

    This is my phone:

    Hardware : MT6735P
    Model : X6pro
    Build number : DOOGEE_X6pro_Android6.0_20160707
    Build date UTC : 20160707-134518
    Android v : 6.0
    Baseband v: X2605_LWG_M0_V0.0.5_S160326, 2016/03/26 14:47
    Kernel v : 3.18.19 (jenkins@80-12) (gcc version 4.9.x-google 20140827 (prerelease) (GCC) ) #1 SMP Thu Jul 7 21:43:21 CST 2016

    • 09/08/2016
      Posts: 7

      I managed to install TWRP but with the latest SP Flash tool "SP_Flash_Tool_v5.1632_Win".

  3. 09/08/2016
    Posts: 7

    Sadly now I get a boot loop, I am still able to enter TWRP tough. This is what I did:

    1- Flashed TWRP 3.0.2 with flash tool. OK

    2- Enter TWRP with power and vol up button. OK

    3- I Allowed TWRP to make system partition modifications. OK

    4- I made a complete backup to sd card. OK

    5- I copied some file from pc to sd card while in TWRP. OK

    6- Reboot. OK

    7- Load Android. FAIL ->boot loop.

  4. 09/08/2016
    Posts: 7

    I flashed Android 6.0 (DOOGEE_X6pro_Android6.0_20160330, the first one) from here: http://www.needrom.com/download/doogee-x6-pro-6-0/ and I got a working OS again.

    Then I installed TWRP, now I selected set /system partition as read only. I rebooted and the OS did load!

    I power off the device, then started in recovery mode BUT TWRP was gone :( I got the normal recovery.

    I flashed again TWRP but now it does not ask about the /system partition. After restart TWRP is gone again…

  5. 09/08/2016
    Posts: 7

    This is very weird I flashed again TWRP and installed supersu from it and now TWRP is kept as the default recovery. Then I flashed the latest stock rom (Doogee X6 Pro –Update 08/08/2016) and with the same procedure TWRP is also kept. Problem solved I guess. Thanks!

Leave a Reply

You must be logged in to post a comment.