• Title: VIBE 1604_Gapps and Root
  • Listed: 01/21/2016 7:21 pm
  • ROM Version: 5.1
  • You must be logged for ROM download.

Overall Rating : 14

4228 total views, 2 today

1 Total favorites


VIBE 1604_Gapps and Root
VIBE 1604_Gapps and Root - Image 1

Author adMember Info


Credits fully applicable to Developer

Install instructions
1. Install Latest custom recovery (TWRP recommended).

2. Copy custom ROM zip file to sd-card (external).

3. Boot into recovery mode.

4. Now select wipe.

5. Advance wipe & select system, data, dalvik cache, cache.

6. Select install & select 1604 DEV.

7. Reboot now

I'm posting it once again with Gapps procedure for 1604 DEV of VIBE UI 3.0

After then reboot so that you will having rooted

Gapps link also given if want install it too….using recovery itself before rebooting itself.

Share Button

※Please make a backup of your device before installing or updating ROM

18 Responses to“VIBE 1604_Gapps and Root”

  1. 01/05/2016
    Posts: 7

    Means after installing this rom twrp get replaced by stock recovery

  2. 01/21/2016
    Posts: 1

    Well, I didnt install the supersu when I was still in recovery mode and now I have the stock recovery. How I can get new recovery now? Like CWM or TWRP. I tried to install CWM like i installed it before but it wasnt working. It said that it installed it correctly but in reboot to recovery there is still that stock recovery.

    • 01/12/2016
      Posts: 103

      no other way agin flash any rooted OS with SP Flash tool or install original Stock ROm using SP Flash tool and root it and install twrp or cwm using flashify.

  3. 10/20/2015
    Posts: 1

    Guys please do not install GAPPS just after flashing the Rom.After Flashing rom reboot the system and configure it,then go to recovery and then flash the GAPPS.
    If u flash GAPPS just after flashing rom, then after reboot the rom will not move past to the welcome screen and says “WLAN stpped working”.

  4. 12/30/2015
    Posts: 2

    MultiLang ?

  5. 11/14/2015
    Posts: 16

    Faulty Rom! I get the error message "This package is for 'aio_otfp' devices …."


    • 01/12/2016
      Posts: 103

      Its not faulty boss it was official from lenovo but a developer version of 1604 VIBE UI 3.0….and keep in mind it was developer version.

  6. 11/14/2015
    Posts: 16

    Why do I get the above error?


  7. ARNAB

    Posts: 23

    the rom installed fine…but its lots nd lots of chinese…FM radio is still playing chinese channels…

    and there is constant roaming icon on the signals….

  8. 01/24/2016
    Posts: 1

    hi boss

    the rom is perfect except one thing

    the IEMI is invailed and ot supported 

    please help

  9. 07/03/2015
    Posts: 7

    can the gapps work on 1604 stable version.???

  10. 02/10/2015
    Posts: 3

    why flashing failed? do i need to do anything before flashing?

Leave a Reply

You must be logged in to post a comment.